Support for Internet Explorer 9

Coinciding with the release of BaseSpace v3.16, we are officially discontinuing support for Internet Explorer 9 (IE9). After April 17, 2015, users will no longer be able to run BaseSpace on IE9.

With the IE browser having undergone two major upgrades (latest version is IE11), we only have a small number of users accessing BaseSpace via IE9. More importantly, with rapid evolution of browser features, the technical burden of supporting old browsers slows down development of newer features.

We apologize for any inconvenience, but encourage you to either upgrade to the latest version of Internet Explorer (IE11), or choose other supporter browsers such as Chrome, Firefox, or Safari.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.